Jump to content

Leaderboard

Popular Content

Showing content with the highest reputation on 09/09/2020 in all areas

  1. Dear Reefers, I am decommissioning my display tank and selling off all livestock, equipment, and even the tank. Livestock includes Finger/leather corals, elegance, green star polyp, anemones, zoa, frogspawn, majestic angel, tomini angel.. Equipment includes very new Maxspect RSX R5-150W. Pls PM me if any interest.
    1 point
  2. 2 pieces Colour as per pics. Green is Lumi bright 2.5” - $60 3.5” - $80 Blastos - 3 big polyps (opens 1.5”) + 2 babies - $80 Collection amk ave 4
    1 point
  3. I have this issue too previously. After troubleshooting, I realise my hose is too long and too many loops. I cut off the excess hose and my flow become ok. Hopefully it helps Sent from Singapore Reef Club mobile app
    1 point
  4. Like Maipian80 mentioned, push your hose all the way in. This to ensure no air is being sucked in. Though this is unlikely the cause of your problem, but just in case. The more likely reason is like what Otaku Reefer mentioned. Due to lost of pressure or pump is set to low flow. What pump (brand/model) are you using? I see that your return hose/pipe outlet is same level as your pump. But what is the height of the chiller, relative to the height of the pump/return? Try troubleshoot like what Otaku mentioned.
    1 point
  5. not expert here but i see that your setup involves a lot a bends and up and down, probably too much for the pump especially the last part like rollercoaster going up ramp, to troubleshoot, i recommend u do the same setup but without the chiller(just make a close loop) den u see if the pump is the issue or not. the pump rating is not so simple one, it may be rated 2500 but u need to count in max height or something. hope it helps. the longer the connection or more kinks and bends the lower the pump efficiency due to drag. Sent from Singapore Reef Club mobile app
    1 point
  6. Just acclimatize your LS slowly to your QT parameters.
    1 point
  7. i think i'll leave it running until my tank is fully stock and i don't expect to add anymore fishes. I will then dry out all equipments/media used and will not used them in my display tank. just keep it incase you need to restart your QT again.
    1 point
  8. Nice fish. Sent from Singapore Reef Club mobile app
    1 point
  9. Part 5 Decided to change my cabinet abit..took out my the cabinet front door and modified it to be my electrical control board..here is the outcome [emoji3] Have not really setup the wires properly as more equipments need to be added..slowly doing up [emoji28] Sent from Singapore Reef Club mobile app
    1 point
  10. Last post for today, a wet quiet Sunday and a long overdue fts. Haven’t post a fts for 5 months. Thanks for viewing. Good night, reefers!!
    1 point
  11. Thank you for the suggestion bro..i will be going for the atlantic v4.... Sent from Singapore Reef Club mobile app
    1 point


  • Newsletter

    Want to keep up to date with all our latest news and information?
    Sign Up
×
×
  • Create New...